off-forum mods not working

  1. 3 years ago

    hello, i'm having some specific issues with some specific mods. i call these mods "off-forum" because they're hosted outside this forum. they are made by ten, who uploaded a directory of mods they've worked on here

    i'm attempting to install their mass deck mod (second file), and their separated trade pile mod (last file on top row) but every time i edit my mods.php, or add ten's mods to func.php directly, when i attempt to load any page it will give me this error:
    Parse error: syntax error, unexpected '=' in /home/erintcg/frozen.fairy-fountain.net/discarded/mods.php on line 5

    the strange thing is, i've gotten these mods working before on a different host, and it was not giving this error before, so i'm not totally sure if this is just my own incompetency at following directions? i'm not sure if this being on a new host is directly part of the problem or not?

    you can see an example of the mass deck mod working here . as far as i know, all the coding is the same as before, nothing has changed except my host/database data in the config file, everything else is the same?

    these would be the only mods i've installed on either host, so i don't think it's other mods conflicting with them either. i've also tried not using mods.php and installing a cust_func.php to see if that would help, but it didn't

    thanks for any and all suggestions and help!

  2. mamori

    12 Sep 2015 Moderator 0

    Could you post your mods.php so we could take a look at it? Looks like there might be a typo in the file.

  3. @mamori Could you post your mods.php so we could take a look at it? Looks like there might be a typo in the file.

    sure thing!

  4. Bloo

    14 Sep 2015 Administrator kablooey.net

    I'm not seeing anything wrong with the code at/around line 5. Is that the exact mods.php that you're using when you get this error?

    Parse error: syntax error, unexpected '=' in /home/erintcg/frozen.fairy-fountain.net/discarded/mods.php on line 5
  5. @Bloo I'm not seeing anything wrong with the code at/around line 5. Is that the exact mods.php that you're using when you get this error?

    Parse error: syntax error, unexpected '=' in /home/erintcg/frozen.fairy-fountain.net/discarded/mods.php on line 5

    hi bloo! yes, it is the same mods.php file i'm using when i get the error on my new host, and it's also the same mods.php file that's actively working on my old host :,)

  6. Bloo

    17 Sep 2015 Administrator kablooey.net

    I'm still not really sure what's wrong with it. XD Try to comment out line 5, like this:

    // $database = new Database;

    Let me know what errors you get~

or Sign Up to reply!