Displaying clickable masteries

  1. 3 years ago

    effy

    16 Sep 2015 http://twig.slothly.org
    Edited 3 years ago by effy

    I can't get this to work. :S I copied my trade post page file from my past trade post and edited it to work with TCGs I use now, and I can't sort out why it's not working, because I used the mastery mod for easyTCG that makes them clickable. >.> It's just showing up blank.

    http://twig.slothly.org/tcg_cosmos.php?mastered

  2. effy

    16 Sep 2015 http://twig.slothly.org

    Never mind! Totally forgot I had had this problem before. .-.

    https://forum.filler00.com/conversation/post/30

  3. effy

    16 Sep 2015 http://twig.slothly.org

    @effy Never mind! Totally forgot I had had this problem before. .-.

    https://forum.filler00.com/conversation/post/30

    Actually, the masteries aren't clickable, and this didn't fix my entire issue. Since I have edited tcg_cosmos.php, however, I'm including the file again. I'm also including func_custom.php to save time in case you want that as well. ^^;

  4. Bloo

    17 Sep 2015 Administrator kablooey.net

    Try this modified 'tcg_cosmos.php' file. Also, if your badges aren't clickable, make sure you've made the following change to your 'func.php' file:

    Replace the following line of code in func.php (should be on or around line 305):

    if ( $row['badge'] !== '' ) { echo '<img src="'.$tcginfo['cardsurl'].''.$row['badge'].'" alt="" title="Mastered '.$mastered.'" /> '; }

    With:

    if ( $row['badge'] !== '' ) { echo '<a href="?mastered='.$row['id'].'"><img src="'.$tcginfo['cardsurl'].''.$row['badge'].'" alt="" title="Mastered '.$mastered.'" /></a> '; }
  5. effy

    29 Sep 2015 http://twig.slothly.org

    I updated func.php; I'm getting blanks for the mastered decks, though. :x
    http://twig.slothly.org/tcg_cosmos.php?mastered=20
    Would it just be best to just create new pages for them?

  6. Bloo

    30 Nov 2015 Administrator kablooey.net

    Sorry for the super late response. :( Been busy packing/moving to a new place the past couple months. OTL

    You need to change this (line ~76):

    <?php } elseif ($_SERVER['QUERY_STRING'] == "mastered") { ?>

    to:

    <?php } elseif (isset($_GET['mastered'])) { ?>

    If that still doesn't work, just let me know! It should work without your needed to create a new page, but there might still be a few more bugs that I didn't catch.

or Sign Up to reply!